Back to overview
Downtime

Outage

Jan 19 at 01:55am CET
Affected services
Earhelp App

Resolved
Jan 21 at 08:57pm CET

Infrastructure issues are resolved.

Created
Jan 19 at 01:55am CET

Application unreachable due to infrastructure issues.